Как решить com.библиотека.android ошибка?

apply plugin: 'com.library.android'
buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:2.0.0'
    }
}

The android studio says plugin with id com.library.androidis not found. I также скачал Android support repository plugin. Это был файл gradle для папки tess two. Как я решаю?

1 ответ

  1. Причина вашей ошибки в том, что вы кладете apply plugin: 'com.library.android'в неправильный файл gradle.

    Есть два файла gradle (если в вашем проекте есть только один модуль). Один-уровень приложенияbuild.gradle, а другой-уровень проекта build.gradle. Те же имена — так, непонятно. Вы используете его в сборке уровня проекта.gradle, где вы не можете держать такие плагины.

    Вырезать apply plugin: 'com.library.android'из текущего gradle и вставить его в сборку уровня приложения.грэдл.