ошибка opencart найдена на моем сайте

Я уже преобразовал свой сайт с одного сервера на другой. Все работает нормально. При попытке открыть мою сторону я нашел это сообщение об ошибке

Deprecated: mysql_connect (): расширение mysql устарело и будет удалено в будущем: используйте mysqli или PDO вместо этого в /home/haratistore/public_html/system/database/mysql.php on line 6

Мой домен http://haratistore.com/
Пожалуйста посоветуйте мне …haw can i fix this type of a error

2 ответа

  1. ОБНОВЛЕНИЕ

    Открыть opencart/config.phpи opencart/admin/config.php.

    Изменить mysqlна mysqli

    например.

    //define('DB_DRIVER', 'mysql');
    define('DB_DRIVER', 'mysqli');
    
  2. Я думаю, что ваша версия Opencart старше 1.5.X так что есть два варианта здесь:

    1) Вы должны обновить OpenCart до 2.x.x

    2) я разработал для старой версии OpenCart PDO класс, который вы должны загрузить в вашей opencart > система > > база данных

    Opencart-PDO