1 ответ

  1. Да, были более ранние версии SOCKS до версии 4, Как видно из следующего комментария в спецификации протокола SOCKS v4:

    http://ftp.icm.edu.pl/packages/socks/socks4/SOCKS4.protocol

    SOCKS был первоначально разработан David Koblas и впоследствии модифицирован
    и расширен мной до текущей версии — version 4
    .

    Это также упоминается в справке по носкам QNX:

    http://www.qnx.com/developers/docs/6.5.0/topic/com.qnx.doc.neutrino_lib_ref/socksappendix.html

    Оригинальные носки были написаны David Koblas (koblas@netcom.com). Протокол SOCKS со временем изменился. Клиентская библиотека, отправленная на момент печати, соответствует SOCKS v4.2. Поскольку сервер и клиенты должны использовать один и тот же протокол SOCKS, эта библиотека не работает с серверами предыдущих версий; клиенты, скомпилированные с этими библиотеками, не будут работать с более старыми серверами .

    И нет, вам не нужно беспокоиться об этих более ранних версиях, поскольку никто их больше не использует. SOCKS4-это минимальная версия, которая все еще используется, хотя socks4a и SOCKS5 являются предпочтительными.