Что не так в моем файле gradle?

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.example.oumnia.advalio"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
        multiDexEnabled true

    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }

    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
        exclude 'META-INF/NOTICE'
        exclude 'META-INF/LICENSE'
        exclude 'META-INF/LICENSE.txt'
        exclude 'META-INF/NOTICE.txt'
    }
    useLibrary 'org.apache.http.legacy'
}

dependencies {
    compile 'com.android.support:appcompat-v7:23.2.0'
    compile 'com.android.support:design:23.2.0'
    compile fileTree(include: ['*.jar'], dir: 'libs')
    //compile 'org.jbundle.util.osgi.wrapped:org.jbundle.util.osgi.wrapped.org.apache.http.client:4.1.2'
    //compile 'com.google.android.gms:play-services:8.4.0'
    compile 'com.google.android.gms:play-services-maps:8.4.0'
    compile 'com.google.android.gms:play-services-location:8.4.0'
    //compile "org.apache.httpcomponents:httpcore:4.2.4"
    //compile "org.apache.httpcomponents:httpmime:4.3"
    //compile project(':httpmime-4.3.1')
    //compile project(':httpcore-4.2.3')
    //compile project(':httpclient-4.5.2')
    compile "org.apache.httpcomponents:httpcore:4.2.4"
    compile "org.apache.httpcomponents:httpmime:4.3"
    compile project(':httpmime-4.3.1')
    compile project(':httpcore-4.2.3')

}

I get this error Error:Execution failed for task’: app: transformClassesWithJarMergingFordebug’.

com.андроид.строить.прикладной программный интерфейс.преобразиться.TransformException: java.util.застежка-молния.ZipException: дубликат записи: org/apache/http / HttpMessage.класс

Кто-нибудь может сказать мне, пожалуйста, что не так в моем файле gradle?

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.example.oumnia.advalio"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
        multiDexEnabled true

    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }

    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
        exclude 'META-INF/NOTICE'
        exclude 'META-INF/LICENSE'
        exclude 'META-INF/LICENSE.txt'
        exclude 'META-INF/NOTICE.txt'
    }
}

dependencies {
    compile 'com.android.support:appcompat-v7:23.2.0'
    compile 'com.android.support:design:23.2.0'
    compile fileTree(include: ['*.jar'], dir: 'libs')
    compile 'org.jbundle.util.osgi.wrapped:org.jbundle.util.osgi.wrapped.org.apache.http.client:4.1.2'
    //compile 'com.google.android.gms:play-services:8.4.0'
    compile 'com.google.android.gms:play-services-maps:8.4.0'
    compile 'com.google.android.gms:play-services-location:8.4.0'
    //compile "org.apache.httpcomponents:httpcore:4.2.4"
    //compile "org.apache.httpcomponents:httpmime:4.3"
    compile project(':httpmime-4.3.1')
    compile project(':httpcore-4.2.3')
}

1 ответ

  1. Удалите Apache lib, если вы пытаетесь скомпилировать с помощью API 23. Или добавьте эту строку внутри тега Android

    useLibrary ‘ org.апаш.http.legacy’