Meteor PKG zimme:ошибки active-route, не может установить пакеты, различные другие вопросы (Meteor)

Я начал свое путешествие с Meteor недавно (супер раздутый)!

Увы! У меня проблемы!

Я не могу, кажется, получить базовое рабочее пространство для работы!

Эта проблема известна здесь:
https://github.com/zimme/meteor-active-route/issues/52


Вот моя проблема подробно:

Спецификации: Win7, 64bit.

Я создаю новое приложение,

> meteor create example 

Это прекрасно работает.

Я запускаю приложение,

> cd example
> meteor 

Это отлично работает.


Эта следующая часть не делает.

Затем я добавляю некоторые пакеты в файл packages ([default] представляет пакеты по умолчанию , установленныеmeteor create, С autopublishи insecureудалены.),

# [default]
kadira:flow-router
kadira:blaze-layout
erasaur:meteor-lodash
mquandalle:stylus
fortawesome:fontawesome
spiderable
fastclick
raix:handlebar-helpers
aldeed:collection2
aldeed:autoform
accounts-ui
accounts-password
matb33:bootstrap-glyphicons
msavin:jetsetter
zimme:active-route
gwendall:auth-client-callbacks

Я тогда начну Метеор снова:

> meteor

Теперь это становится реальным (ly bad).

=> Started proxy.
=> Started MongoDB.
C:UsersPjAppDataLocal.meteorpackagesmeteor-tool

I've started my journey with Meteor recently (super hyped)!

Alas! I'm having some troubles!

I cannot seem to get a basic workspace to work!

This issue is a known issue here: https://github.com/zimme/meteor-active-route/issues/52


Here's my problem detailed:

Specs: Win7, 64bit.

I create a new app,

> meteor create example 

That works fine.

I run the app,

> cd example
> meteor 

That works great.


This next part doesn't.

I then add some packages to the packages file ([default] represents the default packages installed by meteor create, with autopublish and insecure removed.),

# [default]
kadira:flow-router
kadira:blaze-layout
erasaur:meteor-lodash
mquandalle:stylus
fortawesome:fontawesome
spiderable
fastclick
raix:handlebar-helpers
aldeed:collection2
aldeed:autoform
accounts-ui
accounts-password
matb33:bootstrap-glyphicons
msavin:jetsetter
zimme:active-route
gwendall:auth-client-callbacks

I then start Meteor again:

> meteor

Now it gets real(ly bad).

=> Started proxy.
=> Started MongoDB.
C:UsersPjAppDataLocal.meteorpackagesmeteor-tool1.4.2mt-os.windows.x86_3
2dev_bundlelibnode_modulesmeteor-promisepromise_server.js:190
      throw error;
      ^

Error: Extracted archive '/C/Users/Pj/AppData/Local/Temp/.tmpkxwy69' should only
 contain one entry

[ full dump here http://pastebin.com/raw/jSA9N3AF ]

Happens every time, without fail.


FAQ

Q. Have you restarted your machine?

  • Yes. Too many times.

Q. Have you reinstalled Meteor?

  • Multiple times, yes.

Q. Have you deleted the stuff in Local/Temp?

  • Before, after, and during the installs.

Q. Why?

  • I dunno, you tell me!

.4.2mt-os.windows.x86_3
2dev_bundlelibnode_modulesmeteor-promisepromise_server.js:190
throw error;
^

Error: Extracted archive '/C/Users/Pj/AppData/Local/Temp/.tmpkxwy69' should only
contain one entry

[ полная свалка здесь http://pastebin.com/raw/jSA9N3AF ]

Случается каждый раз, в обязательном порядке.


ВОПРОСЫ И ОТВЕТЫ

Вопрос: вы перезапустили машину?

  • Да. Слишком много раз.

Вы переустановили Meteor?

  • Несколько раз, да.

Вы удалили материал в Local / Temp?

  • До, после и во время установки.

Почему?

  • Не знаю, ты мне скажи!

1 ответ

  1. Я думаю, что вам нужно добавить один пакет за раз и посмотреть, где он ломается. Я знаю, что это утомительно, но вы должны найти проблему так или иначе 🙂

    Чтобы сэкономить время, можно использовать метод под названием binary chop (или бинарный поиск) . Добавьте половину пакетов, если это хорошо, Проблема во второй половине списка. Продолжайте рубить, пока не найдете его.