Не удалось прочитать дескриптор артефакта для организации.seleniumhq.selenium: selenium-java: jar:3.0.1

Вот мой пом.XML

<?xml version="1.0" encoding="UTF-8"?>

http://maven.apache.org/xsd/maven-4.0.0.xsd»>
4.0.0

<groupId>test3</groupId>
<artifactId>test3</artifactId>
<version>1.0-SNAPSHOT</version>

<dependency>
    <groupId>junit</groupId>
    <artifactId>junit</artifactId>
    <version>4.12</version>
    <scope>test</scope>
</dependency>


<dependency>
    <groupId>org.apache.poi</groupId>
    <artifactId>poi</artifactId>
    <version>3.15</version>
</dependency>

<dependency>
    <groupId>org.seleniumhq.selenium</groupId>
    <artifactId>selenium-java</artifactId>
    <version>3.0.1</version>
</dependency>


    </dependencies>

Зависимости junit и org.апаш.poi оба работают, я не добавил никаких банок в путь к классу, чтобы заставить их работать, я считаю, что maven загрузил их только из pom, мой код также работает.
Однако при добавлении организации.seleniumhq.Selenium dependence I get the error » не удалось прочитать дескриптор артефакта для организации.seleniumhq.selenium: selenium-java:jar: 3.0.1″ и я не могу использовать какие-либо классы из webdriver.

Почему именно эта зависимость не работает? Что я могу попытаться исправить? Я рыскал stackoverflow и другие ресурсы, чтобы попытаться заставить это работать, любая помощь очень ценится! Спасибо!

2 ответа

  1. У меня была та же проблема, когда я добавлял зависимость для selenium-java-3.0.1.jar, но когда я включил свои настройки.xml ‘путь к файлу в опции Глобальные параметры в’ Windows — > настройки — > > Maven — > > > Настройки пользователя ‘ в eclipse, эта проблема была решена.

  2. У меня была та же проблема. В моем случае это был устаревший пароль для прокси. Проверьте ${user.домашний./}m2 / settings.xml на всякий случай.