ошибка импорта python opencv для 2.7

Я пытался импортировать cv2пакет в windows, и я получил ошибку:

>>> import numpy
>>> numpy.version.version
'1.6.1'
>>> import cv2
RuntimeError: module compiled against API version 0xa but this version of numpy is 0x6

Traceback (последний последний вызов):
Файл»», строка 1, in
импорт cv2
ImportError: numpy.ядро.multiarray не удалось импортировать

Я также попытался numpy verson 1.11.1, но это не сработало.

1 ответ

  1. Вы должны убедиться, что у вас установлена одна версия numpy, предполагая, что вы не работаете в a virtualenv. Python все еще может загружать старый пакет numpy. Если это так, вам нужно будет удалить старую версию или, чтобы сделать вещи проще в долгосрочной перспективе, использовать a virtualenvтолько с пакетами, которые вам нужны.

    Вы можете проверить numpy путь:

    import numpy
    print numpy.__path__