Ошибка подключаемого модуля в Eclipse

Я использую плагин непосредственно из существующей банки. При создании проекта в манифесте появляется ошибка.MF-файл, а также в папке My Referenced Libraries, которая названа в честь идентификатора подключаемого модуля . Но только в этой папке (пакет по умолчанию) в порядке.

Ошибка говорит:

Invalid manifest header Export-Package: ";version="1.0.0""

И местоположение ошибки-строка 1, которая:

Manifest-Version: 1.0.0

И независимо от того, как я изменяю его, он остается ошибкой.

Обновить:

Вот полный манифест: MF

Manifest-Version: 1.0.0
Bundle-ManifestVersion: 2
Bundle-Name: ExcorpPlugin
Bundle-SymbolicName: com.Excorp.PS.ExcorpPlugin
Bundle-Version: 1.0.0
Bundle-ClassPath: .
Bundle-Vendor: EXCORP
Export-Package: ;version="1.0.0"
Bundle-RequiredExecutionEnvironment: JavaSE-1.8

1 ответ

  1. Манифест.линия mf

    Export-Package: ;version="1.0.0"
    

    неправильно, он должен содержать имя пакета, такое как:

    Export-Package: package.name;version="1.0.0"
    

    Удаление строки из манифеста исправит ошибку, но вам нужно исследовать, должен ли плагин экспортировать один или несколько пакетов.