Sqlite 3 не будет установлен в Mono Linux

Я сделал проект и использовал sqlite 3.0 в Visual Studio.Это было обязательным, чтобы перейти на Linux, потому что моя школа использует его, поэтому я передал код в Mono, который работает c# в Linux.Когда я использовал Nuget для загрузки sqlite, я получил это:

Пакет ‘sqlite 3.13.0’ требует NuGet client версии ‘2.12’ или
выше, но текущая версия Nuget — ‘2.8.7.0’.

Я много искал исправление без успеха.Есть ли другой способ установить sqlite?

1 ответ

  1. Можно обновить CIL-сборку Nuget, выполнив:

    sudo nuget update -self
    

    В настоящее время это обновит Nuget до 3.5.0

    т. е.

    >sudo nuget update -self
    Checking for updates from https://www.nuget.org/api/v2/.
    Currently running NuGet.exe 2.12.0.
    Updating NuGet.exe to 3.5.0.