Android Wear Google Play Услуги

Я разрабатываю приложение для Android wear. Во время синхронизации данных я должен использовать сервисы Google Play для обновления информации между устройствами (телефон и износ).
У меня есть некоторые проблемы:

  1. В то время как синхронизация Google Play Services должна обновиться до версии lates. Оригинальная версия 8.7. Но после сикнинга они становятся 9,8 ! Не последний: 10.0.1! Почему? Телефон получил последнюю версию (10.0.1). Таким образом, невозможно синхронизировать данные.

  2. Появится ли эта проблема для опубликованного файла APK? Будут ли пользователи видеть ту же ошибку на своих устройствах? Это проблема только для приложений в разработке? Или что? Я не уверен, что приложение работает правильно на всех устройствах! Я прав?

1 ответ

  1. Единственное решение, которое я нашел, — уменьшить версию сервисов Google Play как в портативных, так и в носимых приложениях.
    compile 'com.google.android.gms:play-services-wearable:9.6.1'