Проблема с настройкой Vulkan API

Я хочу настроить Vulkan API на моей машине Linux Ubuntu 16.04, но это не работает. Я следовал «начало» точно.

Когда я пытаюсь запустить vulkaninfo, я получаю это:

===========
VULKAN INFO
===========

Vulkan API Version: 1.0.37

INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_core_validation.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_api_dump.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_parameter_validation.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_object_tracker.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_monitor.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_threading.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_swapchain.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_vktrace_layer.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_image.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_screenshot.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d/VkLayer_unique_objects.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/.local/share/vulkan/implicit_layer.d/steamoverlay_i386.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /home/adrian/.local/share/vulkan/implicit_layer.d/steamoverlay_x86_64.json, version "1.0.0"
INFO: [loader] Code 0 : Found manifest file /usr/share/vulkan/icd.d/nvidia_icd.json, version "1.0.0"

Instance Extensions:
====================
Instance Extensions count = 4
    VK_KHR_surface                      : extension revision 25
    VK_KHR_xcb_surface                  : extension revision  6
    VK_KHR_xlib_surface                 : extension revision  6
    VK_EXT_debug_report                 : extension revision  2
/home/adrian/vulkan/VulkanSDK/1.0.37.0/examples/vulkaninfo.c:1481: failed with VK_ERROR_INITIALIZATION_FAILED

Когда я пытаюсь запустить cube, я получаю это:

cube: /home/adrian/vulkan/VulkanSDK/1.0.37.0/examples/cube.c:2789: demo_init_vk: Assertion `!err && gpu_count > 0' failed.
Abgebrochen (Speicherabzug geschrieben)

Последнее сообщение означает «прервано» , а затем в скобках » ядро сброшено»

Я правильно настроил переменные среды:

export PATH=$HOME/vulkan/VulkanSDK/1.0.37.0/x86_64/bin
export LD_LIBRARY_PATH=$HOME/vulkan/VulkanSDK/1.0.37.0/x86_64/lib
export VK_LAYER_PATH=$HOME/vulkan/VulkanSDK/1.0.37.0/x86_64/etc/explicit_layer.d

У меня есть Nvidia Geforce GT 730 с драйвером 367.57, который поддерживает Vulkan

Кто-нибудь может мне помочь?

2 ответа

  1. Как часть Vulkan SDK, анализатор установки Vulkan включен (через). Запустите этот инструмент для полного анализа установки. Если вы не понимаете выходные данные, отправьте выходные данные VIA как проблему в LunarXchange (vulkan.lunarg.com) и инженеры LunarG помогут вам. Вы можете найти документацию о том, как запустить VIA в рамках установки SDK, или просмотреть ее на LunarXchange здесь: https://vulkan.lunarg.com/doc/sdk/1.0.37.0/windows/via.html

  2. На дистрибутивах linux это то, что происходит со мной, если я устанавливаю драйвер fake/shim (например, Mesa Intel при отключенном iGPU или Mesa RADV, когда мой GPU все еще не поддерживается).

    Обратите внимание, что ваша карта не указана в списке поддерживаемых Vulkan на этой странице:
    https://developer.nvidia.com/vulkan-driver