WordPress сайт давая AMP ошибки

Мой сайт WordPress дает ошибку AMP и нуждается в некоторой помощи, чтобы исправить ее. Я использую «плагин AMP» для создания страниц AMP. Я также использую «WP-синтаксический плагин», чтобы выделить синтаксис кода.

Проблема в том, что плагин AMP не помещает примеры кодов статей правильно на страницах amp. Например, при преобразовании статьи What is Bootstrap-here в версию amp здесь, он включает в себя примеры кодов в версии amp, из-за которых google показывает ошибки amp на этой странице.

Если вы видите пример кода под текстом («Теперь обратитесь к» bootstrap.css » в заголовке страницы (перед CSS файлами вашего сайта).) «под страницей без усилителя и сравнить сравните ее с версией усилителя, вы увидите, что код не дается в виде текста, но визуализируется.

Это создает большую проблему. Может кто-нибудь есть решение для этого? Спасибо.

1 ответ

  1. Это связано с тем, что Amp в основном является версией strip down или голой версией html html. Плагины не поддерживаются.

    Одна вещь, которую вы можете сделать, это использовать div для кода и дать ему имя класса. А затем добавьте пользовательский css для страниц amp. Таким образом, Вы сможете по крайней мере выделить код из других пунктов.