Импорт Сообщений WordPress-Ошибка Загрузки

Я пытался импортировать сообщения wordpress на мой новый сайт jekyll, используя следующие инструкции: import.jekyllrb.com/docs/wordpress
Но когда я следую этим инструкциям, включая успешную установку «gem install unidecode sequel mysql2 htmlentities» в /Library/Ruby/Gems/2.0.0/gems/mysql2-0.4.5
вроде этого:

ruby -rubygems -e 'require "jekyll-import";
>     JekyllImport::Importers::WordPress.run({
>       "dbname"   => "database_name",
>       "user"     => "user_name",
>       "password" => "mypassword",
>       "host"     => "localhost",
>       "socket"   => "",
>       "table_prefix"   => "wp_",
>       "site_prefix"    => “utf8”,
>       "clean_entities" => true,
>       "comments"       => false,
>       "categories"     => true,
>       "tags"           => true,
>       "more_excerpt"   => true,
>       "more_anchor"    => true,
>       "extension"      => "html",
>       "status"         => ["publish"]
>     })'

Я получаю эту ошибку загрузки:

/System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require': cannot load such file -- jekyll-import (LoadError)  
from   /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in `require'
from -e:1:in `<main>'

Это потому, что мои драгоценные камни находятся в неправильном месте или я установил что-то неправильно?

Мои местоположения:
gem: / usr / bin / gem
ruby: / usr / bin / ruby
jekyll: / usr / local/bin/jekyll


Среда RubyGems:
— RUBYGEMS ВЕРСИЯ: 2.0.14.1
— RUBY версия: 2.0.0 (2015-12-16 patchlevel 648) [универсальный.x86_64-darwin16]
— Каталог установки:/библиотека/Ruby/Gems / 2.0.0
— RUBY исполняемый файл: / System/Library/Framework / Ruby.рамки / версии / 2.0 / usr/bin/ruby
— Исполняемый каталог: / usr / local/bin
— ПЛАТФОРМЫ RUBYGEMS:
— Рубин
— универсальный-Дарвин-16
— GEM ПУТИ:
— /Библиотека / Ruby / Gems / 2.0.0
— /Пользователи / mfrost/.gem / ruby / 2.0.0
— /Система / Библиотека / Фреймворки / Ruby.рамки / версии / 2.0 / usr/lib / ruby/gems / 2.0.0
— КОНФИГУРАЦИЯ САМОЦВЕТА:
— : update_sources = > true>
— : verbose = > true>
— : backtrace = > false
— : bulk_threshold = > 1000>
— УДАЛЕННЫЕ ИСТОЧНИКИ:
https://rubygems.org/


















1 ответ

  1. Похоже, ваш скрипт не может загрузить jekyll-importдрагоценный камень. Убедитесь, что он установлен в соответствии с инструкциями здесь: http://import.jekyllrb.com/docs/installation/

    Если вы нажмете дополнительные ошибки, посмотрите на трассировку стека для необходимых зависимостей во время установки.